View Bug Details

IDProjectCategoryView StatusLast Update
0001799DCP-o-maticBugspublic2020-11-21 22:48
Reportercarl Assigned Tocarl  
PriorityimmediateSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Target Version2.16.0 
Summary0001799: Restrict all Language/Territory codes to meet RFC 5646
Description

Bv2.1 [6.2.1]

Need a UI to set one of the allowed ones; make sure that if they come in wrong with imports they can't get back out again.

TagsNo tags attached.
Branchlanguage-rework
Estimated weeks required
Estimated work requiredUndecided

Relationships

child of 0001798 acknowledged Comply with (or at least warn about deviations from) SMPTE Bv2.1 application profile 

Activities

carl

2020-09-27 22:32

administrator   ~0003949

Last edited: 2020-11-15 23:01

View 10 revisions

May just be the subtitle tab now? And should that go away?

That value is used in

  • cover sheet
  • ISDCF name
  • passed to dcp::InteropSubtitleAsset::set_languageand dcp::SMPTESubtitleAsset::set_language - written literally to theLanguage tags in the XML. SMPTE should be en, en-US, de, de-DE etc (RFC 1766). No idea what Interop should be but the example in the "standard" is Dutch.

One difficulty is that we can (I think) basically specify one language per reel in the DCP. So maybe it's not worth getting the user to set the language of each subtitle content - instead, just the DCP's subtitle language?

carl

2020-11-17 20:10

administrator   ~0004002

Last edited: 2020-11-20 00:01

View 5 revisions

It looks like the language tag in each reel's MainSubtitle should be the same, and that should be the first language in MainSubtitleLanguageList, though others may be added there.
So it seems like we have a definite single "main" subtitle language and then others can be added.

So we could:

  • remove language from text tab for subtitles (ccap have the track thing anyway)
  • in DCP metadata (for both SMPTE/Interop) have a subtitle language
  • use that for the language in MainSubtitleAsset tags, ISDCF name.
  • also for SMPTE allow extra sub languages in metadata, to put in the MainSubtitleLanguageList.

Done on language-rework

carl

2020-11-17 20:14

administrator   ~0004003

Also the closed caption track dialogue has a plain text entry for a language.

carl

2020-11-21 22:48

administrator   ~0004015

I think this is all sorted out now.

Bug History

Date Modified Username Field Change
2020-08-18 19:14 carl New Bug
2020-08-18 19:14 carl Relationship added child of 0001798
2020-09-27 22:32 carl Note Added: 0003949
2020-11-15 20:42 carl Note Edited: 0003949 View Revisions
2020-11-15 20:43 carl Note Edited: 0003949 View Revisions
2020-11-15 20:47 carl Note Edited: 0003949 View Revisions
2020-11-15 20:48 carl Note Edited: 0003949 View Revisions
2020-11-15 20:50 carl Note Edited: 0003949 View Revisions
2020-11-15 20:50 carl Note Edited: 0003949 View Revisions
2020-11-15 20:51 carl Note Edited: 0003949 View Revisions
2020-11-15 20:57 carl Note Edited: 0003949 View Revisions
2020-11-15 23:01 carl Note Edited: 0003949 View Revisions
2020-11-17 20:10 carl Note Added: 0004002
2020-11-17 20:10 carl Note Edited: 0004002 View Revisions
2020-11-17 20:12 carl Note Edited: 0004002 View Revisions
2020-11-17 20:13 carl Note Edited: 0004002 View Revisions
2020-11-17 20:14 carl Note Added: 0004003
2020-11-20 00:01 carl Note Edited: 0004002 View Revisions
2020-11-20 00:02 carl Branch => language-rework
2020-11-20 00:02 carl Estimated work required => Undecided
2020-11-21 22:48 carl Assigned To => carl
2020-11-21 22:48 carl Status new => resolved
2020-11-21 22:48 carl Resolution open => fixed
2020-11-21 22:48 carl Note Added: 0004015