View Bug Details

IDProjectCategoryView StatusLast Update
0001800DCP-o-maticBugspublic2020-12-08 14:53
Reportercarl Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version2.16.0 
Summary0001800: Bv2.1 [7.2] Timed Text restrictions
Description

[]

TagsNo tags attached.
Branchtext-hints hints-about-output
Estimated weeks required
Estimated work requiredUndecided

Relationships

child of 0001798 acknowledged Comply with (or at least warn about deviations from) SMPTE Bv2.1 application profile 

Activities

carl

2020-12-03 22:26

administrator   ~0004042

Last edited: 2020-12-06 19:14

View 8 revisions

  • ClosedCaption XML files must be <= 256kB
  • Total size of one subtitle/closed caption track (XML, PNGs, fonts) must be <= 115MB
  • Fonts must be < 10MB? What about 640KB?

carl

2020-12-06 19:01

administrator   ~0004049

Maybe do this stuff with hints for now, and later maybe we can have some config to make some hints un-ignorable.

carl

2020-12-06 19:16

administrator   ~0004050

The ClosedCaption XML size and the subtitle/ccap MXF size are tricky, since at the moment we don't know these things until after the encode is finished.

  • Check at the end? Oh sorry, that 13 hour encode is wrong and you have to do it again.
  • Somehow build the assets during the hints checking.

carl

2020-12-07 00:27

administrator   ~0004051

Doing approach 0000002 in hints-about-output

carl

2020-12-08 14:53

administrator   ~0004052

cadca6e4f8c1d844f1b5fb9375023e627c674fa9

Bug History

Date Modified Username Field Change
2020-08-18 19:51 carl New Bug
2020-08-18 19:51 carl Relationship added child of 0001798
2020-12-03 22:26 carl Note Added: 0004042
2020-12-03 22:33 carl Note Edited: 0004042 View Revisions
2020-12-04 22:11 carl Note Edited: 0004042 View Revisions
2020-12-04 22:18 carl Note Edited: 0004042 View Revisions
2020-12-05 00:09 carl Branch => text-hints
2020-12-05 00:09 carl Estimated work required => Undecided
2020-12-06 18:58 carl Note Edited: 0004042 View Revisions
2020-12-06 18:59 carl Note Edited: 0004042 View Revisions
2020-12-06 19:01 carl Note Added: 0004049
2020-12-06 19:12 carl Note Edited: 0004042 View Revisions
2020-12-06 19:14 carl Note Edited: 0004042 View Revisions
2020-12-06 19:16 carl Note Added: 0004050
2020-12-07 00:27 carl Branch text-hints => text-hints hints-about-output
2020-12-07 00:27 carl Note Added: 0004051
2020-12-07 12:06 carl Tag Attached: ci
2020-12-07 12:06 carl Status new => acknowledged
2020-12-08 14:53 carl Tag Detached: ci
2020-12-08 14:53 carl Assigned To => carl
2020-12-08 14:53 carl Status acknowledged => resolved
2020-12-08 14:53 carl Resolution open => fixed
2020-12-08 14:53 carl Note Added: 0004052