View Bug Details

IDProjectCategoryView StatusLast Update
0002129DCP-o-maticPackagingpublic2021-12-29 23:30
Reportermarkusk Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform64-bitOSLinuxOS VersionArch
Target Version2.16.0 
Summary0002129: AppImage Error for 2.15.175 .... libgio-2.0.so.0: undefined symbol: g_module_open_full
Description

./DCP-o-matic-2.15.175-x86_64.AppImage ─╯
/tmp/.mount_DCP-o-xeS916/usr/bin/dcpomatic2: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

./DCP-o-matic_Player-2.14.56-x86_64.AppImage ─╯
/tmp/.mount_DCP-o-Ne73sv/usr/bin/dcpomatic2_player: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_module_open_full

Steps To Reproduce

Trying to test the AppImages on Arch linux as a temp step over till openjpeg2 fix is pulled. I'm unable to start these AppImages but others like AudaCity work.

TagsNo tags attached.
Branchappimage-glib-fix
Estimated weeks required
Estimated work requiredUndecided

Activities

carl

2021-12-25 20:39

administrator   ~0004731

https://github.com/project-slippi/Ishiiruka/issues/323

carl

2021-12-25 21:04

administrator   ~0004732

Error also occurs on Fedora 35.

carl

2021-12-25 22:18

administrator   ~0004733

https://gitlab.com/inkscape/inkscape/-/merge_requests/3120

carl

2021-12-25 23:48

administrator   ~0004734

Branch crashes with Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

carl

2021-12-25 23:50

administrator   ~0004735

I built AppImage packages precisely because I thought it would avoid all this sort of thing, so if it doesn't I might just stop making them.

carl

2021-12-29 23:29

administrator   ~0004740

Last edited: 2021-12-29 23:30

Thanks for the report! This should be fixed by 83ae14f5eed0dd9c4fe5d539e18e8cdfdd0ec8bc and 056c4dd82342023636671b1afa333859eed7e32e in v2.15.181.

Bug History

Date Modified Username Field Change
2021-11-19 19:08 markusk New Bug
2021-11-28 21:13 carl Status new => confirmed
2021-11-28 21:13 carl Target Version => 2.16.0
2021-11-28 21:13 carl Estimated work required => Undecided
2021-12-25 20:39 carl Note Added: 0004731
2021-12-25 21:04 carl Note Added: 0004732
2021-12-25 22:18 carl Note Added: 0004733
2021-12-25 23:48 carl Branch => appimage-glib-fix
2021-12-25 23:48 carl Note Added: 0004734
2021-12-25 23:50 carl Note Added: 0004735
2021-12-29 23:29 carl Assigned To => carl
2021-12-29 23:29 carl Status confirmed => resolved
2021-12-29 23:29 carl Resolution open => fixed
2021-12-29 23:29 carl Note Added: 0004740
2021-12-29 23:30 carl Note Edited: 0004740