View Bug Details

IDProjectCategoryView StatusLast Update
0002208DCP-o-maticBugspublic2022-03-17 23:17
Reportercarl Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.16.4 
Target Version2.16.x 
Summary0002208: Screens are not in the correct order in KDM emails
Description

i.e. not in the order in the cinema list.

TagsNo tags attached.
Branch2208-screens-ordering
Estimated weeks required
Estimated work requiredUndecided

Activities

carl

2022-03-11 21:09

administrator   ~0004921

We're using a map to store them, and the order of selection seems to be important.

carl

2022-03-14 21:34

administrator   ~0004932

Just checking with reporter that things on this branch are OK.

carl

2022-03-14 22:11

administrator   ~0004933

Things are not OK:
"when I load certificate from a file, it is added to the cinamas XML with full path - I guess this is a new feature"
Sorting is wrong e.g. Í is before A
Writing a folder for each cinema's KDM fails when the filenames get long.

carl

2022-03-14 22:22

administrator   ~0004934

The path thing I think is not a bug.
Sorting seems right on Linux, need to test on Windows.

carl

2022-03-17 21:53

administrator   ~0004953

Hopefully all fixed on the branch.

carl

2022-03-17 23:17

administrator   ~0004954

f1f30972e5d1dee08a607a05b6d782540c11595e

Bug History

Date Modified Username Field Change
2022-03-11 19:13 carl New Bug
2022-03-11 21:09 carl Reproducibility have not tried => always
2022-03-11 21:09 carl Estimated work required => Undecided
2022-03-11 21:09 carl Note Added: 0004921
2022-03-11 21:09 carl Assigned To => carl
2022-03-11 21:09 carl Status new => confirmed
2022-03-11 21:41 carl Branch => 2208-screens-ordering
2022-03-11 21:41 carl Status confirmed => in progress
2022-03-14 21:34 carl Target Version 2.16.x => 2.16.8
2022-03-14 21:34 carl Status in progress => feedback
2022-03-14 21:34 carl Note Added: 0004932
2022-03-14 22:09 carl Status feedback => in progress
2022-03-14 22:09 carl Target Version 2.16.8 => 2.16.x
2022-03-14 22:11 carl Note Added: 0004933
2022-03-14 22:22 carl Note Added: 0004934
2022-03-17 21:53 carl Note Added: 0004953
2022-03-17 23:17 carl Status in progress => resolved
2022-03-17 23:17 carl Resolution open => fixed
2022-03-17 23:17 carl Note Added: 0004954