View Bug Details

IDProjectCategoryView StatusLast Update
0002248DCP-o-maticBugspublic2022-05-11 19:38
Reportercarl Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Target Version2.16.11 
Summary0002248: dcpomatic2_kdm_cli fails to find files with non-US-ASCII filenames on Windows
Description

https://dcpomatic.com/forum/viewtopic.php?t=1861

TagsNo tags attached.
Branch2248-utf8-arg-hack
Estimated weeks required
Estimated work requiredUndecided

Activities

carl

2022-05-08 20:56

administrator   ~0005009

Looks like we may have to switch to boost program_options instead of getopt and use wmain / GetCommandLineW

carl

2022-05-09 21:57

administrator   ~0005015

2248-utf8-arg-hack may also be OK, getting the UTF16 command line, converting to UTF8 and passing to the existing code.

carl

2022-05-09 22:54

administrator   ~0005016

Asked the reporter to check that build on the forum.

carl

2022-05-11 19:38

administrator   ~0005020

bbe336ee97c86c424f8f94e0f947f8e3b20e7123

Bug History

Date Modified Username Field Change
2022-05-08 20:50 carl New Bug
2022-05-08 20:50 carl Status new => confirmed
2022-05-08 20:50 carl Estimated work required => Undecided
2022-05-08 20:56 carl Note Added: 0005009
2022-05-09 21:56 carl Branch => 2248-utf8-arg-hack
2022-05-09 21:57 carl Note Added: 0005015
2022-05-09 22:54 carl Assigned To => carl
2022-05-09 22:54 carl Status confirmed => in progress
2022-05-09 22:54 carl Status in progress => feedback
2022-05-09 22:54 carl Note Added: 0005016
2022-05-11 19:38 carl Status feedback => resolved
2022-05-11 19:38 carl Resolution open => fixed
2022-05-11 19:38 carl Note Added: 0005020