View Bug Details

IDProjectCategoryView StatusLast Update
0002258DCP-o-maticBugspublic2022-05-22 20:34
Reportercarl Assigned Tocarl  
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Target Version2.16.12 
Summary0002258: Using OpenGL mode on macOS makes the program crash without any error
Description

2.16.10 is affect, 2.16.8 is OK.

TagsNo tags attached.
Branch
Estimated weeks required
Estimated work required

Activities

carl

2022-05-22 19:53

administrator   ~0005034

Last edited: 2022-05-22 20:34

Bisect suggests the problem is d5c059a2ff ("Primitive auto-crop (0001477)")

carl

2022-05-22 20:34

administrator   ~0005035

2d53b0ad98dd010bab33c3db83c89b264ff1e9bb

carl

2022-05-22 20:34

administrator   ~0005036

glLineWidth != 1.0 fails on macOS (we've seen this before).

Bug History

Date Modified Username Field Change
2022-05-22 13:18 carl New Bug
2022-05-22 13:18 carl Assigned To => carl
2022-05-22 13:18 carl Status new => confirmed
2022-05-22 19:53 carl Note Added: 0005034
2022-05-22 20:34 carl Status confirmed => resolved
2022-05-22 20:34 carl Resolution open => fixed
2022-05-22 20:34 carl Note Added: 0005035
2022-05-22 20:34 carl Note Added: 0005036
2022-05-22 20:34 carl Note Edited: 0005034