View Bug Details

IDProjectCategoryView StatusLast Update
0002264DCP-o-maticBugspublic2022-06-07 16:01
Reportercarl Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Target Version2.16.14 
Summary0002264: DoM does not search the system for the .ttf/.otf for a fonts specified by (e.g.) an ASS files
Description

If the font isn't configured in the content we give up and use the default. Instead (at some point) we should probably search the system for a font which matches the name and use that.

TagsNo tags attached.
Branch2264-system-font-files{,-take2,-take3}
Estimated weeks required
Estimated work requiredUndecided

Relationships

related to 0002262 feedbackcarl Some .ASS formatting details not respected 

Activities

carl

2022-05-30 23:57

administrator   ~0005048

Some hacks on 2264-system-font-files

carl

2022-05-31 14:34

administrator   ~0005052

Last edited: 2022-05-31 14:58

A related problem seems to be that we have one font ID (TEXT_FONT_ID) for non-DCP subs so we can't even support multiple fonts.

carl

2022-06-05 21:02

administrator   ~0005056

@carl: test/merge

carl

2022-06-07 16:01

administrator   ~0005069

280a456ae1da8fa648be1e9f68140f045b306e32

Bug History

Date Modified Username Field Change
2022-05-30 22:36 carl New Bug
2022-05-30 22:36 carl Assigned To => carl
2022-05-30 22:36 carl Status new => confirmed
2022-05-30 22:36 carl Relationship added related to 0002262
2022-05-30 23:57 carl Branch => 2264-system-font-files
2022-05-30 23:57 carl Estimated work required => Undecided
2022-05-30 23:57 carl Note Added: 0005048
2022-05-31 14:34 carl Note Added: 0005052
2022-05-31 14:58 carl Note Edited: 0005052
2022-05-31 19:54 carl Branch 2264-system-font-files => 2264-system-font-files{,-take2}
2022-06-03 19:20 carl Branch 2264-system-font-files{,-take2} => 2264-system-font-files{,-take2,-take3}
2022-06-03 19:20 carl Status confirmed => in progress
2022-06-05 21:02 carl Note Added: 0005056
2022-06-07 16:01 carl Status in progress => resolved
2022-06-07 16:01 carl Resolution open => fixed
2022-06-07 16:01 carl Note Added: 0005069