View Bug Details

IDProjectCategoryView StatusLast Update
0002367DCP-o-maticBugspublic2022-11-21 19:10
ReporterIoannisSyrogiannis Assigned Tocarl  
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Platform64-bitOSWindowsOS Version10
Product Version2.16.31 
Target Version2.16.34 
Summary0002367: Srt subtitles showing not according to DCP creation
Description

The srt subtitles are showing on the screen and on player higher than set on the authoring program.

Steps To Reproduce

Add srt subtitles, both as OV and VF

Additional Information

The subtitles have black outline. Shouldn't be relevant.

Tagscurrent, srt, subtitles
Branch2637-sub-position
Estimated weeks required
Estimated work requiredUndecided

Activities

IoannisSyrogiannis

2022-11-17 08:09

reporter  

image.png (1,065,566 bytes)
image-2.png (1,485,875 bytes)

carl

2022-11-17 19:08

administrator   ~0005302

Are you making interop or SMPTE DCPs?

IoannisSyrogiannis

2022-11-17 20:29

reporter   ~0005303

They are Interop

carl

2022-11-17 21:16

administrator   ~0005304

Thanks. Looks like the player displays the DCP correctly, but the DoM preview is wrong. Or, to put it another way, we're not writing the correct DCP to reflect what's shown in the preview.

carl

2022-11-17 23:26

administrator   ~0005306

Last edited: 2022-11-18 09:57

@carl tricky case is interop dcp input -> smpte output (or vice versa) as then you need to know the height and baseline of the text; and if you guess, it would be nice to render that guess in the preview rather than using it for the first time in DCP.

IoannisSyrogiannis

2022-11-18 08:41

reporter   ~0005307

You are correct on the DoM - Player note. The VF I made, I did because the OV had the subtitles too high. So I tried again, but they were still higher than wanted.
I don't think it makes a difference, but when I checked them on-screen, the rendering was taking place on the projector, not on the server side.

carl

2022-11-20 23:31

administrator   ~0005318

There is a test build here: https://dcpomatic.com/temp/2637-sub-position/755c873/ which should fix these problems, if you would like to try it.

IoannisSyrogiannis

2022-11-21 00:55

reporter   ~0005319

I will. Even though I noticed the same on different DCPs made, I will use the original project I wrote about and -then- I will try another one.

IoannisSyrogiannis

2022-11-21 08:15

reporter   ~0005320

From Author to Player, the position seems consistent with this version (blury image -> DCP-o-matic Player).
I'd like to check on-screen as well. I will add another note later.

image-3.png (264,506 bytes)
image-4.png (256,760 bytes)   
image-4.png (256,760 bytes)   

carl

2022-11-21 08:19

administrator   ~0005321

Thank you!

IoannisSyrogiannis

2022-11-21 17:05

reporter   ~0005322

Well, acknowledgement is in order from my side mostly.
In any case: I won't add a multi MegaPixel photo of the cinema screen. The subtitles are consistently displayed there as well, you may file this bug as squashed.

carl

2022-11-21 19:08

administrator   ~0005323

Thanks for checking and getting back to me!

carl

2022-11-21 19:10

administrator   ~0005324

323b8cbb0b95297fbd027ffdc4ea5003b59ef25f

Bug History

Date Modified Username Field Change
2022-11-17 08:09 IoannisSyrogiannis New Bug
2022-11-17 08:09 IoannisSyrogiannis Tag Attached: current
2022-11-17 08:09 IoannisSyrogiannis Tag Attached: srt
2022-11-17 08:09 IoannisSyrogiannis Tag Attached: subtitles
2022-11-17 08:09 IoannisSyrogiannis File Added: image.png
2022-11-17 08:09 IoannisSyrogiannis File Added: image-2.png
2022-11-17 19:08 carl Assigned To => carl
2022-11-17 19:08 carl Status new => feedback
2022-11-17 19:08 carl Note Added: 0005302
2022-11-17 20:29 IoannisSyrogiannis Note Added: 0005303
2022-11-17 20:29 IoannisSyrogiannis Status feedback => assigned
2022-11-17 21:09 carl Status assigned => confirmed
2022-11-17 21:09 carl Priority normal => high
2022-11-17 21:09 carl Target Version => 2.16.34
2022-11-17 21:09 carl Estimated work required => Undecided
2022-11-17 21:16 carl Note Added: 0005304
2022-11-17 23:22 carl Status confirmed => in progress
2022-11-17 23:26 carl Note Added: 0005306
2022-11-17 23:33 carl Note Edited: 0005306
2022-11-18 08:41 IoannisSyrogiannis Note Added: 0005307
2022-11-18 09:57 carl Note Edited: 0005306
2022-11-18 09:57 carl Branch => 2637-sub-position
2022-11-20 23:31 carl Note Added: 0005318
2022-11-21 00:55 IoannisSyrogiannis Note Added: 0005319
2022-11-21 06:53 carl Status in progress => feedback
2022-11-21 08:15 IoannisSyrogiannis Note Added: 0005320
2022-11-21 08:15 IoannisSyrogiannis File Added: image-3.png
2022-11-21 08:15 IoannisSyrogiannis File Added: image-4.png
2022-11-21 08:15 IoannisSyrogiannis Status feedback => assigned
2022-11-21 08:19 carl Note Added: 0005321
2022-11-21 17:05 IoannisSyrogiannis Note Added: 0005322
2022-11-21 19:08 carl Note Added: 0005323
2022-11-21 19:10 carl Status assigned => resolved
2022-11-21 19:10 carl Resolution open => fixed
2022-11-21 19:10 carl Note Added: 0005324