View Bug Details

IDProjectCategoryView StatusLast Update
0000835DCP-o-matic[All Projects] Featurespublic2018-01-05 13:04
ReporterCarstenAssigned Tocarl 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionreopened 
PlatformMacOSOS XOS Version10.6
Product Version 
Target Version2.12.0Fixed in Version 
Summary0000835: colour audio level channel designations in audio analysis window with the same color that their graphs show
Description

colouring the DCP audio channel designators in the same colors that their respective graphs show makes it easier to identify individual channels.

TagsNo tags attached.
Estimated work requiredAverage

Activities

carl

2017-10-13 22:40

administrator   ~0001828

Nice idea, implemented in 0c54ae8d45449b20afda7a3bc006a90ed0c6952a

Carsten

2017-11-12 18:27

manager   ~0001842

Hmm, I remember I recently saw the colored audio graph designators, but now miss them...then I remembered I saw them in the windows version 2.11.27 - but the audio graph legend doesn't show up colored in OS X (2.11.27, missing in both 10.6.8 and Sierra), it stays plain black. However, the graph itself and colored high gain shows up in colors as always.

  • Carsten

Carsten

2018-01-02 12:18

manager   ~0001885

colored audio graph legend also missing in 2.11.34 in OS X Sierra



carl

2018-01-04 22:47

administrator   ~0001910

Looks like a bug in wxWidgets fixed by their commit 31ba2d4ca393a6fda6af409d37f1aa2de9946d43
Will try applying this to my OS X wxWidgets to see if it helps.

carl

2018-01-05 13:04

administrator   ~0001916

Should be fixed by patch to wxWidgets in my build environment; fix will be in 2.11.36.

Bug History

Date Modified Username Field Change
2016-04-01 11:41 Carsten New Bug
2017-10-13 22:40 carl Assigned To => carl
2017-10-13 22:40 carl Status new => resolved
2017-10-13 22:40 carl Resolution open => fixed
2017-10-13 22:40 carl Note Added: 0001828
2017-11-12 18:27 Carsten Status resolved => feedback
2017-11-12 18:27 Carsten Resolution fixed => reopened
2017-11-12 18:27 Carsten Note Added: 0001842
2017-12-06 00:48 carl Target Version => 2.12.0
2018-01-02 12:18 Carsten File Added: Bildschirmfoto 2018-01-02 um 13.17.18.png
2018-01-02 12:18 Carsten Note Added: 0001885
2018-01-02 12:18 Carsten Status feedback => assigned
2018-01-04 22:47 carl Note Added: 0001910
2018-01-05 13:04 carl Status assigned => resolved
2018-01-05 13:04 carl Note Added: 0001916