View Issue Details

IDProjectCategoryView StatusLast Update
0000824DCP-o-matic[All Projects] Bugspublic2016-07-04 14:06
ReporterCarstenAssigned Tocarl 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.6
Product Version2.7.0 
Target Version2.8.0Fixed in Version 
Summary0000824: Catch condition when fader calculator values are given with decimal comma , instead of decimal point
DescriptionDOM crashes hard when a fader value for the level calculator is entered with decimal comma instead of decimal point. I doubt many people use this feature, still, the crash should be avoided, as many people around the world are unsafe which format to use when asked to enter decimal values.

See screenshot.

- Carsten
TagsNo tags attached.
Estimated work requiredAverage

Activities

Carsten

2016-03-11 23:06

reporter  

Carsten

2016-03-11 23:13

reporter  

decimal_comma.jpg (28,729 bytes)
decimal_comma.jpg (28,729 bytes)

Carsten

2016-03-11 23:14

reporter   ~0001168

...especially since close to the fader calculator, some localized languages display decimal comma for gain and peak level ;-)

carl

2016-03-13 01:46

administrator   ~0001171

Fixed in 1a1d4b22589d5832dd594a65054d9261f9f496cf and the previous commit.

Issue History

Date Modified Username Field Change
2016-03-11 23:06 Carsten New Issue
2016-03-11 23:06 Carsten File Added: crash_fader_calculator.jpg
2016-03-11 23:13 Carsten File Added: decimal_comma.jpg
2016-03-11 23:14 Carsten Note Added: 0001168
2016-03-12 01:20 carl Target Version => 2.8.0
2016-03-13 01:46 carl Note Added: 0001171
2016-03-13 01:46 carl Status new => resolved
2016-03-13 01:46 carl Resolution open => fixed
2016-03-13 01:46 carl Assigned To => carl