View Issue Details

IDProjectCategoryView StatusLast Update
0001304DCP-o-matic[All Projects] Featurespublic2019-06-02 23:16
Reporterelia.orselli Assigned Tocarl  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version2.16.0Fixed in Version 
Summary0001304: SMPTE FFMC
Description

I think it would be usefull to add FFMC (first frame of moving/main credits) marker in SMPTE DCPs
Ex.: https://dci.foxpico.com/basic/plugfest/som-marker-test.tar (dcp test from http://isdcf.com/ISDCF/test-content.html)

TagsNo tags attached.
Estimated work requiredMedium

Relationships

related to 0000782 acknowledged CPL metadata 

Activities

Carsten

2018-05-18 18:37

manager   ~0002439

Last edited: 2018-05-18 18:45

View 4 revisions

Yup. Metadata, incl. Marker is on a to-do list. The trouble is, how to create a usable GUI method. These markers belong to the DCP domain, so should be accessed somewhere under the DCP tab. And we would need to cue to that position in the timeline, then use that position to add markers based on a captured timecode from that timeline position.

Maybe add a third tab under 'DCP', in addition to 'Video' and 'Audio'. I guess it's easy to add this to the GUI and project XML file format, but I guess Carl needs to enhance his dcp/XML libraries to support it? Also, this tab should only be active for SMPTE DCPs.

Under this new tab, there could be a list of different marker types with input fields, and options to fill them either manually, or by picking TC from the playback playhead (as under Content->Timing). Once this list is enabled in GUI and supported in the xml/dcp libs, one could add more standard metadata tags as needed, even add custom tags as allowed per SMPTE CPL metadata spec.

  • Carsten

Carsten

2018-05-18 18:37

manager  

carl

2018-05-20 00:43

administrator   ~0002444

Alternatively, the preview is pretty much the "DCP domain" so maybe some way of setting up markers there? I'm thinking little draggable arrows under the time slider, or something? Maybe you could right-click them and choose "to timeline position." Then we could have some detailed descriptions and editable controls in a new tab like you suggest.

carl

2018-05-20 19:17

administrator   ~0002446

Also are any servers reading these markers yet?

elia.orselli

2018-05-20 21:48

reporter   ~0002448

Christie says that IMB-S2 reads FFMC markers, I'll try the test dcp asap.

elia.orselli

2018-05-21 13:27

reporter   ~0002449

Yes: Christie IMB-S2 shows markers in details tab



Screenshot_76.png (29,011 bytes)
Screenshot_76.png (29,011 bytes)

Carsten

2018-05-22 09:29

manager   ~0002455

Doremi allows to populate Cue TC from certain marker types. I think Dolby as well. Alchemy/ICMP is about to have it, there is some functionality to add cues from TC already, guess FFMC is around the corner.

Sláinte from Ireland - Carsten

carl

2019-02-08 00:05

administrator   ~0003054

FFOC/LFOC - first/last frame of composition intended for display
FFTC/LFTC - first/last frame of title credits
FFOI/LFOI - first/last frame of intermission
FFOB/LFOB - first/last frame of ratings band
FFEC/LFEC - first/last frame end credits
FFMC/LFMC - first/last frame moving credits

Carsten

2019-02-08 01:16

manager   ~0003057

Last edited: 2019-02-09 16:08

View 5 revisions

While it is true that preview could accomodate these markers, having all these markers would eat up space there unnecessarily.
Also, we need more Metadata with no reference to the preview. So, I guess it would be better to sum all metadata incl markers under a dedicated tab under DCP, and allow to populate those marker fields with a timecode reference from the playhead as with trimming. It would also be helpful if e.g. a click on the Marker timecode would send the playhead to that position in preview. I also guess that general metadata can be extensive once established, so I guess we need a scrollable table. Each entry could have an option to be selected from a drop-down list showing allowed metadata tags, followed by a value field. Some fields could be preoccupied from DCP parameters (e.g. resolution, aspect ratio, language). In the long term, one would probably need ways to weigh DCNC vs. metadata. They should comply. DCP-o-matic's DCNC detail input dialog also takes up that sort of data. Maybe these GUI elements need to be revised at some point. But for now, I think a separate Metadata tab is best.

  • Carsten

carl

2019-06-02 23:16

administrator   ~0003365

This is more-or-less done in v2.15.x.

Issue History

Date Modified Username Field Change
2018-05-17 04:55 elia.orselli New Issue
2018-05-18 18:37 Carsten File Added: Bildschirmfoto 2018-05-18 um 20.29.13.png
2018-05-18 18:37 Carsten Note Added: 0002439
2018-05-18 18:37 Carsten File Deleted: Bildschirmfoto 2018-05-18 um 20.29.13.png
2018-05-18 18:37 Carsten Note Edited: 0002439 View Revisions
2018-05-18 18:37 Carsten File Added: Bildschirmfoto 2018-05-18 um 20.28.05.png
2018-05-18 18:41 Carsten Note Edited: 0002439 View Revisions
2018-05-18 18:45 Carsten Note Edited: 0002439 View Revisions
2018-05-20 00:43 carl Note Added: 0002444
2018-05-20 00:43 carl Assigned To => carl
2018-05-20 00:43 carl Status new => acknowledged
2018-05-20 19:16 carl Target Version => 2.14.0
2018-05-20 19:17 carl Note Added: 0002446
2018-05-20 21:48 elia.orselli Note Added: 0002448
2018-05-21 13:27 elia.orselli File Added: Screenshot_76.png
2018-05-21 13:27 elia.orselli Note Added: 0002449
2018-05-22 09:29 Carsten Note Added: 0002455
2018-10-17 09:39 carl Estimated work required Unknown => Average
2018-10-17 09:40 carl Estimated work required Average => Medium
2018-11-12 00:38 carl Target Version 2.14.0 =>
2019-01-29 17:49 carl Target Version => 2.16.0
2019-01-29 17:53 carl Relationship added related to 0000782
2019-02-08 00:05 carl Note Added: 0003054
2019-02-08 01:16 Carsten Note Added: 0003057
2019-02-08 01:22 Carsten Note Edited: 0003057 View Revisions
2019-02-08 01:25 Carsten Note Edited: 0003057 View Revisions
2019-02-08 01:32 Carsten Note Edited: 0003057 View Revisions
2019-02-09 16:08 Carsten Note Edited: 0003057 View Revisions
2019-06-02 23:16 carl Status acknowledged => resolved
2019-06-02 23:16 carl Resolution open => fixed
2019-06-02 23:16 carl Note Added: 0003365