View Bug Details

IDProjectCategoryView StatusLast Update
0001387DCP-o-matic[All Projects] i18npublic2018-11-07 02:35
ReporterrobnAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionreopened 
Platformx86_64OSFedoraOS Version27
Product Version 
Target VersionFixed in Version 
Summary0001387: hard-coded English text in UI
Description

Part of the crash error pop-up has hard-coded (non-translated) English text.
See attached example picture.

Tested with DOM 2.13.62.

Steps To Reproduce

Make DOM crash .. :-)

(for example with https://dcpomatic.com/mantis/view.php?id=1386 )

TagsNo tags attached.
Estimated work requiredUnknown

Activities

robn

2018-10-20 05:23

reporter  

translation.png (17,751 bytes)
translation.png (17,751 bytes)

carl

2018-10-20 20:26

administrator   ~0002730

Thanks, should be fixed by 07e6c3270cad21adf2a52064b5b283defad79228

Carsten

2018-10-27 12:04

manager   ~0002736

Last edited: 2018-10-27 12:10

View 4 revisions

I consider it good practice to have the actual error message in english, and not translate it. Because they will most likely be reported on the forum, mailing list, and here, and an error message translated into an exotic language won't help Carl getting to the cause.

In this case, though, that has not happened. I guess the introduction, and the request to contact Carl should be translatable, and the technical error description should stay in english. Similarly for the log, if not better keep the log all english. Anyone with an interest in log reading should be able to understand enough english, and a log sent to Carl in greek or chinese probably won't help much. Even though he could probably translate it back to english from the .po files ;-)

The trouble for translators is that some strings in the po files might be used in the UI AND the log creating, and even if they are only used in the log creating or error message display, it is hard to identify these strings and their turning up there. At a time I was translating quite a few strings without thinking much about them, and only later saw they ended up in the log, but nowhere in the UI.

  • Carsten

robn

2018-11-07 02:35

reporter   ~0002756

This problem appears not to be solved: it still exists in DOM 2.13.66

Bug History

Date Modified Username Field Change
2018-10-20 05:23 robn New Bug
2018-10-20 05:23 robn File Added: translation.png
2018-10-20 20:26 carl Assigned To => carl
2018-10-20 20:26 carl Status new => resolved
2018-10-20 20:26 carl Resolution open => fixed
2018-10-20 20:26 carl Note Added: 0002730
2018-10-27 12:04 Carsten Note Added: 0002736
2018-10-27 12:07 Carsten Note Edited: 0002736 View Revisions
2018-10-27 12:09 Carsten Note Edited: 0002736 View Revisions
2018-10-27 12:10 Carsten Note Edited: 0002736 View Revisions
2018-11-07 02:35 robn Status resolved => feedback
2018-11-07 02:35 robn Resolution fixed => reopened
2018-11-07 02:35 robn Note Added: 0002756