View Bug Details

IDProjectCategoryView StatusLast Update
0001393DCP-o-matic[All Projects] Bugspublic2019-02-09 20:14
ReporterCarstenAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.12
Product Version2.12.x 
Target Version2.14.0Fixed in Version 
Summary0001393: Color options 'missing' for bitmap subs?
Description

Hi Carl,

I just wanted to reproduce a workflow I used last year, removing opacity from DVD bitmap subs, and noticed that in 2.12 the subtitle appearance dialog looks completely different from 2.10.5, which I used last time. So, in 2.12.x, it seems I can not change the color table of bitmap subs at all?

See attached screenshot - this is how it looks like in 2.10.5.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Activities

Carsten

2018-10-27 16:12

manager  

carl

2018-10-29 01:01

administrator   ~0002747

Those controls are behind the "Appearance..." button in the subtitle tab. However, they don't work any more because we no longer scan the whole of a subtitled video file on import, so we no longer find all the colours that subtitles can be.

It would probably be best if a "deep" inspection were triggered when the appearance box was opened, otherwise we'd be doing potentially long scans which the majority of users wouldn't need.

Carsten

2018-10-29 11:03

manager   ~0002748

Last edited: 2018-10-29 11:04

View 3 revisions

Hmm, I saw the remains (unpopulated) of that dialog in the current version and suspected something like that. While I am all for reducing analysis and prechecking times, I guess it is bad to miss something like this by trying to save some time. Wouldn't it be possible to perform all checks in parallel (multithreaded), so one check delivers all information - audio, video, and general content parameters?

  • Carsten

carl

2018-10-29 23:53

administrator   ~0002749

Worst case (e.g. a BluRay rip) you need to run through 30-odd GB of data; the problem is more the disk IO rather than the processing so I don't think multithreading would help that much.

carl

2019-01-25 00:11

administrator   ~0002936

I've added an on-demand subtitle scanner to 4fb4b414b70cb38d405b6c3dd6c12b6a4d918d40

In 2.13.109 DoM should run a scan when you open subtitle appearance, and colour controls should appear shortly after.

Let me know what you think if you get chance to test it!

Carsten

2019-01-25 01:11

manager   ~0002937

Good idea!

  • Carsten

Carsten

2019-01-26 14:41

manager   ~0002953

Last edited: 2019-01-26 14:58

View 4 revisions

The subtitle scanner starts when I open the Appearance dialog - but only the color black is 'detected', unlike the full set in 2.10.5 as shown above. The search run doesn't take too long, maybe a minute or so for a full length feature.

  • Carsten

P.S. - disable ineffective subtitle appearance controls for bitmap subtitles? Also, disable 'closed captions' for bitmap subtitles?
Is it possible that e.g. an MKV contains both bitmap subs AND timed text? I understand there is a timed text subtitle option for some container types?



Bildschirmfoto 2019-01-26 um 15.39.21.png (308,013 bytes)

Carsten

2019-01-26 15:01

manager   ~0002954

Also - since the scan only takes a minute or so for a full length feature with many subtitles (a singalong version) - is it really necessary to do this separately, instead of immediately after import during initial content inspection? Compared to e.g. audio analysis, this is really quick...

  • Carsten

carl

2019-01-26 20:00

administrator   ~0002958

Missing detected colours should be fixed by 0e6d4402c013eb6be666b5f638dd932052ae6c51

carl

2019-01-26 20:00

administrator   ~0002959

Was your test feature a Bluray rip?

Carsten

2019-01-26 20:10

manager   ~0002960

Yes. I mean NO, NO, NO, NO....

carl

2019-01-26 20:31

administrator   ~0002961

Interesting. Perhaps it can skip over the video data without reading it.

Carsten

2019-01-26 20:36

manager   ~0002962

Last edited: 2019-01-26 20:41

View 5 revisions

Maybe one special case of many possible container specific data arrangements? In this case, this was a video/audio MKV, with the bitmap subs/VOB added later using MKV merging. So, certainly a bit special. Maybe the subtitle part added that way was a contiguous piece around the end or the beginning, not interleaved?

I mean, I don't care to open that appearance dialog to trigger it.
Just wondering if skipping that full analysis right after adding content could have other negative consequences. So far, it seems, not many complained since 2.10.5, though ...

  • Carsten

carl

2019-01-26 20:41

administrator   ~0002963

Yeah the main disadvantage of not doing a full sub scan on import is that you can't e.g. disable CCAP/appearance as there might be a mixture of bitmap and text subs (seems unlikely though).

carl

2019-01-27 23:38

administrator   ~0002974

Just tried a BR rip off a spinning-rust drive and it took about 3 mins to scan the subs.

carl

2019-02-08 22:01

administrator   ~0003060

OK I've disabled the closed caption option for subs in FFmpeg files; they could be text, but let's just see how common that is, and if anybody needs to make them into closed caps.

Carsten

2019-02-09 16:07

manager   ~0003063

One could think there is little need for adjusting bitmap colors, but let's remember, DCP-o-matic started as DVD-o-Matic, and I know many small cinemas showing rare content with no DCPs available, and often foreign language films. Very often, the VOB subs on these discs need to be adjusted in some way to make them 'compatible' with cinema screenings. E.g. if you shift them into the visible image area from letterbox bars, very often color adjustments are necessary.

Also wondering wether adding a bounding box with color selection could be a useful addition for all burn-in subs.

carl

2019-02-09 20:14

administrator   ~0003064

Sure. I don't think anything here will prevent that, will it? 0001233 is the feature request for bounding box.

Bug History

Date Modified Username Field Change
2018-10-27 16:12 Carsten New Bug
2018-10-27 16:12 Carsten Status new => assigned
2018-10-27 16:12 Carsten Assigned To => carl
2018-10-27 16:12 Carsten File Added: Bildschirmfoto 2018-10-27 um 18.03.51.png
2018-10-27 16:15 Carsten Description Updated View Revisions
2018-10-29 01:01 carl Note Added: 0002747
2018-10-29 11:03 Carsten Note Added: 0002748
2018-10-29 11:04 Carsten Note Edited: 0002748 View Revisions
2018-10-29 11:04 Carsten Note Edited: 0002748 View Revisions
2018-10-29 23:53 carl Note Added: 0002749
2018-11-08 01:31 carl Status assigned => confirmed
2019-01-25 00:11 carl Status confirmed => feedback
2019-01-25 00:11 carl Note Added: 0002936
2019-01-25 01:11 Carsten Note Added: 0002937
2019-01-25 01:11 Carsten Status feedback => assigned
2019-01-25 21:36 carl Status assigned => resolved
2019-01-25 21:36 carl Resolution open => fixed
2019-01-26 14:41 Carsten File Added: Bildschirmfoto 2019-01-26 um 15.39.21.png
2019-01-26 14:41 Carsten Note Added: 0002953
2019-01-26 14:55 Carsten Note Edited: 0002953 View Revisions
2019-01-26 14:57 Carsten Note Edited: 0002953 View Revisions
2019-01-26 14:58 Carsten Note Edited: 0002953 View Revisions
2019-01-26 15:01 Carsten Note Added: 0002954
2019-01-26 20:00 carl Note Added: 0002958
2019-01-26 20:00 carl Note Added: 0002959
2019-01-26 20:01 carl Status resolved => assigned
2019-01-26 20:10 Carsten Note Added: 0002960
2019-01-26 20:31 carl Note Added: 0002961
2019-01-26 20:36 Carsten Note Added: 0002962
2019-01-26 20:36 Carsten Note Edited: 0002962 View Revisions
2019-01-26 20:38 Carsten Note Edited: 0002962 View Revisions
2019-01-26 20:38 Carsten Note Edited: 0002962 View Revisions
2019-01-26 20:41 Carsten Note Edited: 0002962 View Revisions
2019-01-26 20:41 carl Note Added: 0002963
2019-01-27 23:38 carl Note Added: 0002974
2019-02-08 22:01 carl Status assigned => resolved
2019-02-08 22:01 carl Note Added: 0003060
2019-02-09 16:07 Carsten Note Added: 0003063
2019-02-09 20:14 carl Note Added: 0003064