View Bug Details

IDProjectCategoryView StatusLast Update
0001441DCP-o-matic[All Projects] Clean-uppublic2019-02-07 22:55
ReporterCarstenAssigned Tocarl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.12
Product Version2.14.0 
Target Version2.14.0Fixed in Version 
Summary0001441: Always throw warnings with non standard frame rates 24fps-2D/48fps-3D), no matter wether Interop or SMPTE.
Description

A warning/hint should always be issued whenever a non 24/48fps DCP will be created. While many different frame rates are allowed for SMPTE DCPs, even full SMPTE compliant equipment in the field very often does not support all these frame rates.
We also probably need a dedicated hint text towards this. I get many complaints about non working DCPs, and then it turns out they are 50fps or 60fps - or even just 25fps...

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Relationships

has duplicate 0001169 resolvedcarl Always warn if frame rates other than 24(2D) or 48(3D) is set for DCP, even if SMPTE wrapping is active 

Activities

carl

2019-01-25 21:34

administrator   ~0002941

We have SMPTE systems in the field that don't support 25fps?!

Carsten

2019-01-26 19:59

manager   ~0002957

Last edited: 2019-01-26 20:18

View 10 revisions

Yes. The SMPTE compliance is more on the server software side (metadata interpretation, MXF parsing). Where the frame rate capability usually is implemented (or not) in the media block. Dolby managed to make the old DSS100 SMPTE compatible, but it still only supports 24fps (48fps 3D). SMPTE compliance does not include a systems actual capability to play all SMPTE compliant frame rates :-(

But not only that outdated DSS100 is a problematic case - all those systems using a HD-SDI connection towards the server suffer from frame rate limitations in some ways. Some older GDC and Qube servers also suffer similar issues.

I wouldn't care much if frame rates >30fps could only be created using expensive pro equipment (which was the case until a few years back) by educated people.

Unfortunately, many customer type cameras now even default to 50 or 60 fps. Without any warning or hint, people create 50 or 60 fps DCPs without even knowing (I get this type of complaint every few weeks in different places).

I would even go as far as automatically choosing 24 fps from 24/25/50fps and 30fps from 60fps per default as 'use best'.

People need to actively override this choice manually. That could be expressed in the hints dialog as well:

'DCP-o-matic has deliberately chosen a lower frame rate because your source footage uses high frame rates that may not play correctly on many projection systems currently in the field. If you are positively sure about creating a High Frame Rate DCP, you need to adjust the frame rate under the DCP tab manually. Do not choose frame rates other than 24 fps light heartedly'.

This is more or less what I tell people in the german translation currently for Interop frame rate collisions.

This becomes increasingly important as more and more people believe they should create SMPTE DCPs, and with DCP-o-matic creating SMPTE DCP per default at some near point in the future (personally, I hope/vote not before 2.16 ;-) )

  • Carsten

carl

2019-01-26 22:50

administrator   ~0002970

The point of this SMPTE transition seems to be evaporating before my eyes! But at least we have encrypted subtitles: phew! ;)

078a0f98e3f741210be7f839292f41f28b6a403e chooses 24/25/30 for 48/50/60 content unless the user overrides, and adds a hint.

Maybe we should also default to 24 for 25 content. I'd really like some numbers about how many non-25 systems there are in the field, but I don't suppose that information is especially easy to find.

carl

2019-02-07 22:55

administrator   ~0003052

Warnings in place for all non 24/48 rates in 9b4c2ae80d83d4e91c2fe9c6704a22aaeb3ee734

Bug History

Date Modified Username Field Change
2019-01-05 19:43 Carsten New Bug
2019-01-05 19:43 Carsten Status new => assigned
2019-01-05 19:43 Carsten Assigned To => carl
2019-01-05 19:44 Carsten Description Updated View Revisions
2019-01-25 21:34 carl Note Added: 0002941
2019-01-26 19:59 Carsten Note Added: 0002957
2019-01-26 20:01 Carsten Note Edited: 0002957 View Revisions
2019-01-26 20:01 Carsten Note Edited: 0002957 View Revisions
2019-01-26 20:02 Carsten Note Edited: 0002957 View Revisions
2019-01-26 20:03 Carsten Note Edited: 0002957 View Revisions
2019-01-26 20:05 Carsten Note Edited: 0002957 View Revisions
2019-01-26 20:06 Carsten Note Edited: 0002957 View Revisions
2019-01-26 20:16 Carsten Note Edited: 0002957 View Revisions
2019-01-26 20:17 Carsten Note Edited: 0002957 View Revisions
2019-01-26 20:18 Carsten Note Edited: 0002957 View Revisions
2019-01-26 22:50 carl Note Added: 0002970
2019-02-01 00:30 carl Relationship added has duplicate 0001169
2019-02-07 22:55 carl Status assigned => resolved
2019-02-07 22:55 carl Resolution open => fixed
2019-02-07 22:55 carl Note Added: 0003052