View Bug Details

IDProjectCategoryView StatusLast Update
0001457DCP-o-matic[All Projects] Bugspublic2019-02-19 23:52
ReporterCarstenAssigned Tocarl 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSOS XOS Version10.12
Product Version2.12.x 
Target Version2.14.0Fixed in Version 
Summary0001457: In OS X, assigned subtitle fonts are not used for burn-in.
Description

Instead, 'some' system font is used for burn-in. I guess LiberationSans-Regular.

When doing timed-text, the assigned font is used and copied to the subtitle folder/MXF (SMPTE).
If no specific font is assigned, LiberationSans-Regular is used.

  • Carsten
TagsNo tags attached.
Estimated work requiredUnknown

Relationships

related to 0001322 resolvedcarl DoM picks "light" style rather than the "normal" one if there are multiple styles on the machine 

Activities

carl

2019-02-08 00:12

administrator   ~0003055

Last edited: 2019-02-08 21:04

View 4 revisions

Trying fontconfig backend to fix this; get a pango error that only coretext is enabled. Fix this then try again.

OSX environment build is failing for 32-bit (sigc++, when building examples, glibmm missing sigc++) - possibly fixed now (re-running). Maybe because Xcode got updated to 10.1 whose ld outputs a deprecation warning when it links i386. This seems to break lots of configure scripts. Downloaded 9.4.1 and ran xcode-select to enable it.

carl

2019-02-09 00:37

administrator   ~0003061

44996fb5279ca8dc2b4dc4aca841896c25b5e928 along with changes to the build environment (bumping harfbuzz) fixes this; need to see if there are consequences for rendering quality.

Carsten

2019-02-18 22:59

manager   ~0003096

Need to do more testing, but basically, it works in OS X now.

I will try to render the same project using the same font files on both Win and Mac and see wether there are differences.

  • Carsten

carl

2019-02-18 23:10

administrator   ~0003098

Cool, thanks. I'm hoping things should be more consistent across platforms now, as they all use freetype.

Carsten

2019-02-19 23:52

manager   ~0003101

Okay, after loading a new font, the preview is not immediately updated with the new glyps. I need to save and reload the project. No big deal, but maybe...

  • Carsten

Bug History

Date Modified Username Field Change
2019-02-01 23:46 Carsten New Bug
2019-02-01 23:46 Carsten Status new => assigned
2019-02-01 23:46 Carsten Assigned To => carl
2019-02-03 00:25 carl Relationship added related to 0001322
2019-02-07 21:37 carl Status assigned => confirmed
2019-02-08 00:12 carl Note Added: 0003055
2019-02-08 00:16 carl Note Edited: 0003055 View Revisions
2019-02-08 00:30 carl Note Edited: 0003055 View Revisions
2019-02-08 21:04 carl Note Edited: 0003055 View Revisions
2019-02-09 00:37 carl Note Added: 0003061
2019-02-18 22:59 Carsten Note Added: 0003096
2019-02-18 23:10 carl Status confirmed => resolved
2019-02-18 23:10 carl Resolution open => fixed
2019-02-18 23:10 carl Note Added: 0003098
2019-02-19 23:52 Carsten Note Added: 0003101