View Bug Details

IDProjectCategoryView StatusLast Update
0001936DCP-o-maticBugspublic2021-03-29 22:27
Reportermhm Assigned Tocarl  
PriorityimmediateSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform64-bitOSWindowsOS Version10
Target Version2.16.0 
Summary0001936: Some Unicode-characters are not displayed correctly on Windows
Description

Some Unicode characters (->, superscript "2") are not displayed correctly on Windows. Using DoM v2.15.136 on Windows 10. Please see screenshots.

TagsNo tags attached.
Branch
Estimated weeks required
Estimated work requiredUndecided

Activities

mhm

2021-03-21 22:48

reporter  

carl

2021-03-21 23:40

administrator   ~0004181

@carl looks like we need wxString::FromUTF8 on these UTF8-encoded constant strings.

carl

2021-03-29 22:26

administrator   ~0004201

Last edited: 2021-03-29 22:27

Accidentally squashed into 79e711cb33c182e48c1d33d3e9f1df1c41c122a6so this should be fixed in 2.15.137.

Bug History

Date Modified Username Field Change
2021-03-21 22:48 mhm New Bug
2021-03-21 22:48 mhm File Added: Screenshot 2021-03-21 at 23.39.42.png
2021-03-21 22:48 mhm File Added: Screenshot 2021-03-21 at 23.38.30.png
2021-03-21 23:39 carl Priority normal => immediate
2021-03-21 23:39 carl Target Version => 2.16.0
2021-03-21 23:39 carl Estimated work required => Undecided
2021-03-21 23:40 carl Note Added: 0004181
2021-03-21 23:40 carl Status new => acknowledged
2021-03-29 22:26 carl Note Added: 0004201
2021-03-29 22:27 carl Note Edited: 0004201
2021-03-29 22:27 carl Assigned To => carl
2021-03-29 22:27 carl Status acknowledged => resolved
2021-03-29 22:27 carl Resolution open => fixed